wordpressのバージョンアップ

今日のニュースを読んでたら「wordpressに脆弱性あり」とか出てたので、バージョンアップしてみた。

http://www.itmedia.co.jp/news/articles/0804/30/news010.html

プログラムを

http://ja.wordpress.org/

よりダウンロードして、作業開始。

インストールディレクトリはDocumentRootだったので、

# rsync -av htdocs/ htdocs.bak/

でバックアップ後、

http://***/wp-admin/upgrade.php

を実行するが、動かず。apacheのエラーログに”max_allowed_packet”が云々とエラーが出ていたので、一時的にサイズを大きくしてmysql再起動後、再度実行したところ、エラーは消えた。テーブルorカラムが新規追加された模様。

トップページにアクセスするが表示されず。

.htaccessを、~/htdocs.bak/からコピーして表示された。

テンプレートテーマが新しい方に存在してなかったので、~/htdocs.bak/wp-content/themes/から新しい方にコピーして、以前のデザインが蘇った。

wordpressはほぼ動的表示なので、MTと違い問題の箇所の特定は容易であるが、PHPの知識が無い人は注意すべきである。

残念ながら、脆弱性対策以外、目を見張る機能は無かった。。。

カテゴリー: 技術関連 タグ: パーマリンク